---
title: Install radvd-gael on elementary OS using the Snap Store | Snapcraft
description: Get the latest version of radvd-gael for on elementary OS - Router Advertisement
  Daemon
url: https://snapcraft.io/install/radvd-gael/elementary
---

[Canonical Snapcraft](https://snapcraft.io/)

# Install radvd-gael on **elementary OS**

# radvd-gael

[Gael LeGoff (gael-legoff)](https://snapcraft.io/publisher/gael-legoff "View all snaps from Gael LeGoff (gael-legoff)")

* [Gael LeGoff (gael-legoff)](https://snapcraft.io/publisher/gael-legoff "View all snaps from Gael LeGoff (gael-legoff)")
* [Server and Cloud](https://snapcraft.io/search?categories=server-and-cloud)

[Install](https://snapcraft.io/install/radvd-gael/elementary#install)

#### Router Advertisement Daemon

*This is NOT an original piece of work, just a snap of radvd*

The Router Advertisement Daemon (radvd) is an open-source software product that implements link-local advertisements of IPv6 router addresses and IPv6 routing prefixes using the Neighbor Discovery Protocol (NDP) as specified in RFC 2461.

This product includes software developed by the authors which are mentioned at the start of the source files and other contributors.

**Authors of radvd**

* Lars Fenneberg [lf@elemental.net](mailto:lf@elemental.net)

**First use**

* Grant firewall-control to radvd-gael to the daemon (mandatory)
  `sudo snap connect radvd-gael:firewall-control`
* Grant network-control to radvd-gael to radvdump (optional)
  `sudo snap connect radvd-gael:network-control`
* Configure radvd daemon
  `sudo vi /var/snap/radvd-gael/current/radvd.conf`
* Restart the service
  `sudo systemctl restart snap.radvd-gael.radvd.service`
* Check the logs
  `sudo snap logs radvd-gael.radvd`
* Dump ICMPv6 packets
  `sudo radvd-gael.radvdump`
  or
  `sudo tcpdump -n -i <<YOUR_INTERFACE>> icmp6`

**2026-05-26**

* v2.21 on amd64, armhf & arm64
* All the details are here <https://github.com/radvd-project/radvd/releases/tag/v2.21>

**2025-04-27**

* Improvements, up to git commit 878ca6b (2025-04-25)
* Increase max AdvDefaultLifetime and MaxRtrAdvInterval (RFC8319 support)

**2024-12-31**

* v2.20 on amd64, armhf & arm64

**2024-10-31**

* radvd-gael will now use core24 as most users are on Ubuntu 24.04

**2024-03-06**

* radvd-gael version 2.20-rc.1 promoted to stable after 4 months of edge testing

**2023-07-26**

* radvd-gael will now use core22 as most users are on Ubuntu 22.04

**2022-10-03**

* Improvements, up to git commit c8a11fd (2022-09-08)
* Fix case of AdvValidLifetime option

**2022-07-10**

* Improvements, up to git commit a646066 (2022-07-08)
* Add pref64 support (RFC8781)

**2022-06-30**

* Improvements, up to git commit b0cb5a2 (2022-06-30)
* Change RDNSS and DNSSL lifetime default values

**2022-06-11**

* Improvements, up to git commit e1f9dbc (2022-06-11)
* Add IPV6\_DROP\_MEMBERSHIP to clean up resources when reload or restart

**2022-05-31**

* Improvements, up to git commit 16e1139 (2022-03-20)

**2021-03-22**

* First release of radvd-gael v2.19 on amd64, armhf & arm64

### Package name

* radvd-gael

---

### License

* BSD-4-Clause

---

### Last updated

* 26 May 2026 - latest/stable
* 7 September 2026 - latest/edge

---

### Contact

* [github.com/gael-legoff/radvd-gael/issues](https://github.com/gael-legoff/radvd-gael/issues "https://github.com/gael-legoff/radvd-gael/issues")

---

##### Report a Snap Store violation

* [Report this Snap](https://snapcraft.io/install/radvd-gael/elementary#report-snap-modal)

---

## Enable snaps on elementary OS and install radvd-gael

Snaps are applications packaged with all their dependencies to run on all popular Linux distributions from a single build. They update automatically and roll back gracefully.

Snaps are discoverable and installable from the [Snap Store](https://snapcraft.io/store), an app store with an audience of millions.

### Enable snapd

Snap can be installed on elementary OS from the command line. Open *Terminal* from the Applications launcher and type the following:

```
sudo apt update
sudo apt install snapd
```

Either log out and back in again, or restart your system, to ensure snap’s paths are updated correctly.

### Install radvd-gael

To install radvd-gael, simply use the following command:

```
sudo snap install radvd-gael
```

### Other popular snaps…

[See more...](https://snapcraft.io/search?categories=featured)

[See more in Featured](https://snapcraft.io/search?categories=featured)

### More things to do…

#### [Get the snap store](https://snapcraft.io/snap-store)

Browse and find snaps from the convenience of your desktop using the snap store snap.

#### [Learn more about snaps](https://snapcraft.io/docs)

Interested to find out more about snaps? Want to publish your own application? Visit [snapcraft.io](https://snapcraft.io/) now.

[Back to top](https://snapcraft.io/install/radvd-gael/elementary)

© 2026 Canonical Ltd.
Ubuntu and Canonical are registered trademarks of Canonical Ltd.

Powered by [Charmed Kubernetes](https://www.ubuntu.com/kubernetes)

[Join the forum](https://forum.snapcraft.io/), contribute to or report problems with,
[snapd](https://bugs.launchpad.net/snapd),
[Snapcraft](https://bugs.launchpad.net/snapcraft),
or [this site](https://github.com/canonical/snapcraft.io/issues/new).

* [Share on Twitter](https://twitter.com/snapcraftio)
* [Share on Facebook](https://www.facebook.com/snapcraftio)
* [Share on YouTube](https://www.youtube.com/snapcraftio)

* [Terms of Service](https://ubuntu.com/legal/terms-and-policies/snap-store-terms)
* [Data privacy](https://www.ubuntu.com/legal/data-privacy)
* [Manage your tracker settings](https://snapcraft.io/install/radvd-gael/elementary)
* [Service status](https://status.snapcraft.io/)
* [Other functions](https://dashboard.snapcraft.io/)
* [Contact us](https://snapcraft.io/about/contact-us)
