---
title: Install radvd-gael on Linux | Snap Store
description: Get the latest version of radvd-gael for Linux - Router Advertisement
  Daemon
url: https://snapcraft.io/radvd-gael
---

# radvd-gael

[Gael LeGoff (gael-legoff)](https://snapcraft.io/publisher/gael-legoff "View all snaps from Gael LeGoff (gael-legoff)")

* [Gael LeGoff (gael-legoff)](https://snapcraft.io/publisher/gael-legoff "View all snaps from Gael LeGoff (gael-legoff)")
* [Server and Cloud](https://snapcraft.io/search?categories=server-and-cloud)

latest/stable v2.21

Install latest/stable of radvd-gael

---

**Install using the command line**

```
sudo snap install radvd-gael
```

Don't have snapd? [Get set up for snaps](https://snapcraft.io/docs/installing-snapd).

---

### Package name

* radvd-gael

---

### License

* BSD-4-Clause

---

### Last updated

* 26 May 2026 - latest/stable
* 7 September 2026 - latest/edge

---

### Contact

* [github.com/gael-legoff/radvd-gael/issues](https://github.com/gael-legoff/radvd-gael/issues "https://github.com/gael-legoff/radvd-gael/issues")

---

##### Report a Snap Store violation

* [Report this Snap](https://snapcraft.io/radvd-gael#report-snap-modal)

---

* [Description](https://snapcraft.io/radvd-gael#tab-description)
* [Security](https://snapcraft.io/radvd-gael#tab-security)

#### Router Advertisement Daemon

*This is NOT an original piece of work, just a snap of radvd*

The Router Advertisement Daemon (radvd) is an open-source software product that implements link-local advertisements of IPv6 router addresses and IPv6 routing prefixes using the Neighbor Discovery Protocol (NDP) as specified in RFC 2461.

This product includes software developed by the authors which are mentioned at the start of the source files and other contributors.

**Authors of radvd**

* Lars Fenneberg [lf@elemental.net](mailto:lf@elemental.net)

**First use**

* Grant firewall-control to radvd-gael to the daemon (mandatory)
  `sudo snap connect radvd-gael:firewall-control`
* Grant network-control to radvd-gael to radvdump (optional)
  `sudo snap connect radvd-gael:network-control`
* Configure radvd daemon
  `sudo vi /var/snap/radvd-gael/current/radvd.conf`
* Restart the service
  `sudo systemctl restart snap.radvd-gael.radvd.service`
* Check the logs
  `sudo snap logs radvd-gael.radvd`
* Dump ICMPv6 packets
  `sudo radvd-gael.radvdump`
  or
  `sudo tcpdump -n -i <<YOUR_INTERFACE>> icmp6`

**2026-05-26**

* v2.21 on amd64, armhf & arm64
* All the details are here <https://github.com/radvd-project/radvd/releases/tag/v2.21>

**2025-04-27**

* Improvements, up to git commit 878ca6b (2025-04-25)
* Increase max AdvDefaultLifetime and MaxRtrAdvInterval (RFC8319 support)

**2024-12-31**

* v2.20 on amd64, armhf & arm64

**2024-10-31**

* radvd-gael will now use core24 as most users are on Ubuntu 24.04

**2024-03-06**

* radvd-gael version 2.20-rc.1 promoted to stable after 4 months of edge testing

**2023-07-26**

* radvd-gael will now use core22 as most users are on Ubuntu 22.04

**2022-10-03**

* Improvements, up to git commit c8a11fd (2022-09-08)
* Fix case of AdvValidLifetime option

**2022-07-10**

* Improvements, up to git commit a646066 (2022-07-08)
* Add pref64 support (RFC8781)

**2022-06-30**

* Improvements, up to git commit b0cb5a2 (2022-06-30)
* Change RDNSS and DNSSL lifetime default values

**2022-06-11**

* Improvements, up to git commit e1f9dbc (2022-06-11)
* Add IPV6\_DROP\_MEMBERSHIP to clean up resources when reload or restart

**2022-05-31**

* Improvements, up to git commit 16e1139 (2022-03-20)

**2021-03-22**

* First release of radvd-gael v2.19 on amd64, armhf & arm64

---

## Install radvd-gael on your Linux distribution

Choose your Linux distribution to get detailed installation instructions. If yours is not shown, get more details on the [installing snapd documentation](https://snapcraft.io/docs/installing-snapd).

[### Arch Linux](https://snapcraft.io/install/radvd-gael/arch)

[### CentOS](https://snapcraft.io/install/radvd-gael/centos)

[### Debian](https://snapcraft.io/install/radvd-gael/debian)

[### elementary OS](https://snapcraft.io/install/radvd-gael/elementary)

[### Fedora](https://snapcraft.io/install/radvd-gael/fedora)

[### KDE Neon](https://snapcraft.io/install/radvd-gael/kde-neon)

[### Kubuntu](https://snapcraft.io/install/radvd-gael/kubuntu)

[### Manjaro](https://snapcraft.io/install/radvd-gael/manjaro)

[### Pop!\_OS](https://snapcraft.io/install/radvd-gael/pop)

[### openSUSE](https://snapcraft.io/install/radvd-gael/opensuse)

[### Red Hat Enterprise Linux](https://snapcraft.io/install/radvd-gael/rhel)

[### Ubuntu](https://snapcraft.io/install/radvd-gael/ubuntu)

[### Raspberry Pi](https://snapcraft.io/install/radvd-gael/raspbian)
