Crossfire - Client

Install latest/stable of Crossfire - Client

Ubuntu 16.04 or later?

Make sure snap support is enabled in your Desktop store.


Install using the command line

sudo snap install crossfire

Don't have snapd? Get set up for snaps.

Channel Version Published

Client for the multiplayer RPG Crossfire

Client for the multiplayer RPG Crossfire

Details for Crossfire - Client

License
  • unset

Last updated
  • 14 April 2023 - latest/stable
  • 27 January 2024 - latest/edge

Websites

Contact

Share this snap

Generate an embeddable card to be shared on external websites.


Install Crossfire - Client on your Linux distribution

Choose your Linux distribution to get detailed installation instructions. If yours is not shown, get more details on the installing snapd documentation.


Where people are using Crossfire - Client

Is there a problem with Crossfire - Client? Report this app