Strictly NetBeans

Install latest/stable of Strictly NetBeans

Ubuntu 16.04 or later?

Make sure snap support is enabled in your Desktop store.


Install using the command line

sudo snap install strictly-netbeans

Don't have snapd? Get set up for snaps.

Channel Version Published

Apache NetBeans® in a strictly-confined snap

Apache NetBeans is an integrated development environment (IDE) for Java, with extensions for PHP, C, C++, HTML5, JavaScript, and other languages. Applications based on NetBeans, including the NetBeans IDE, can be extended by third-party developers.

This package provides the latest release of NetBeans built directly from its source code on GitHub. If the OpenJDK Snap package is also installed, this package connects to it automatically for the location of its Java Development Kit.

This Snap package is strictly confined, running in complete isolation with only limited access to your system. For important information about running NetBeans in a confined environment, see the README file for this package on GitHub:

https://github.com/jgneff/strictly-netbeans

This is a convenience binary of the NetBeans IDE and not a release by the Apache Software Foundation. For official releases, see:

https://netbeans.apache.org

Apache NetBeans and the NetBeans logo are either registered trademarks or trademarks of the Apache Software Foundation in the United States and/or other countries.

Details for Strictly NetBeans

License
  • Apache-2.0

Last updated
  • 20 February 2024 - latest/stable
  • 23 May 2024 - latest/candidate

Contact

Share this snap

Generate an embeddable card to be shared on external websites.


Install Strictly NetBeans on your Linux distribution

Choose your Linux distribution to get detailed installation instructions. If yours is not shown, get more details on the installing snapd documentation.


Where people are using Strictly NetBeans

Users by distribution (log)

Debian 12
Ubuntu 22.04
Raspbian 11

Is there a problem with Strictly NetBeans? Report this app