golangci-lint

golangci-lint

Alex Murray (alexmurray) Publisher Star developer Star developer

Install latest/stable of golangci-lint

Ubuntu 16.04 or later?

Make sure snap support is enabled in your Desktop store.


Install using the command line

sudo snap install golangci-lint

Don't have snapd? Get set up for snaps.

Channel Version Published

Fast linters runner for Go

Runs linters in parallel, uses caching, supports yaml config, has integrations with all major IDE and has dozens of linters included.

Details for golangci-lint

License
  • GPL-3.0-only

Last updated
  • 25 August 2022

Links

Share this snap

Generate an embeddable card to be shared on external websites.


Related blog posts


Where people are using golangci-lint

Users by distribution (log)

Ubuntu 20.04
Ubuntu 22.04
Ubuntu 18.04
Ubuntu 21.10
Ubuntu 21.04
Linux Mint 20.3
pop 22.04
Manjaro
Ubuntu 16.04
Zorin OS 16
Debian 11
pop 20.04

Install golangci-lint on your Linux distribution

Choose your Linux distribution to get detailed installation instructions. If yours is not shown, get more details on the installing snapd documentation.


Is there a problem with golangci-lint? Report this app